Announcement Announcement Module
Collapse
No announcement yet.
Big Problems Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Big Problems

    I powered down my VB via the GUI during a power outage (I have a backup power supply).

    My VB wouldn't reboot when I powered it back on...turns out I had a "bad number in superblock" which I could not fix using fsck.

    So...I reinstalled 2.0...and am still having problems. The message I see now is "no IP address for eth0 (DHCP not working)

    What can I do?

  • #2
    Power down your VB. Reboot your router. Power up your VB.

    Comment


    • #3
      Thanks Ron...what command do I use to power down?

      Comment


      • #4
        Two ways to do it:

        1. Click the Power Down button on the VB GUI System Configuration page http://vortexbox/system.php

        OR

        2. Login to your VB and enter
        Code:
        poweroff

        Comment


        • #5
          Thank you again - I dont have GUI access at the moment

          Comment


          • #6
            Well, I tried that but I am still getting the same message and cannot access my VB

            Comment


            • #7
              Try assigning a static IP address to the VB. See http://info.vortexbox.org/tiki-index...tic+IP+Address. Use the following command:
              Code:
              system-config-network

              Comment


              • #8
                Well...I'm lost. I have no idea how to assign a static IP directly via the keyboard and monitor. Is there a step-by-step guide? Shall I contact Andrew?

                Honestly, it is terribly disappointing - this is the third time I have had to reinstall after an inability to boot. I love that my VB is so stable on a daily basis but I dread every time it has to be powered down for exactly this reason.

                Comment


                • #9
                  Read the wiki page carefully -- it gives instructions on how to configure a static IP address. Study it until you understand it. You must know the IP address of your router, and its DHCP pool range. Consult your router user guide for this info. When logged into your VB, enter the system-config-network command and select the appropriate options. You should be able to do this.

                  It's best to keep your VB running 24/7 if possible to minimize problems.

                  You can also try a full network power cycle as described here: http://info.vortexbox.org/tiki-index...age=PowerCycle
                  Make sure to power cycle your Internet modem as well as your router. Follow the wiki instructions.

                  Then if that doesn't work, try a static IP address.

                  Comment


                  • #10
                    Ron - I do appreciate your help. I can only log in via the monitor and keyboard. I can certainly see the options for system-config-network but it will not let me toggle to the static IP fields. It's not intuitive and the wiki page has detailed instructions only for the web GUI. The only instructions for the monitor method is "choose the appropriate options for to set up a DHCP or static IP address.

                    Comment


                    • #11
                      Use the Tab and arrow keys to navigate in system-config-network. Use the space bar to unset "Use DHCP".

                      Did you try power cycling your Internet modem, router, and VortexBox? If not, try this first.
                      DHCP failures can often be fixed this way. Do this as specified in the wiki page http://info.vortexbox.org/tiki-index...age=PowerCycle

                      Comment


                      • #12
                        I CAN do that...what I cannot do is enter anything into the static IP boxes. It is not select-able.

                        Comment


                        • #13
                          In system-config-network, navigate to the "Use DHCP" field with the down-arrow key. There is a * there. Hit the space bar. This will remove the * and let you enter info in the Static IP fields.

                          Please power cycle your network and report the results.

                          Comment


                          • #14
                            OK - it's fixed. I was trying to access my VB via \\vortexbox and it was not on the network. It was, however assigned an IP address which I was able to find by using ifconfig per Andrew's suggestion.

                            Thank you again Ron - your help is appreciated.

                            Comment


                            • #15
                              Now that you can find the VortexBox on your network, I still recommend setting it up with a static IP address. You can do this from the VB GUI Network Configuration page http://vortexbox/network.php or http://<vortexbox-ip-address>/network.php.

                              Comment

                              Working...
                              X